Volvo V40 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So I've had my D2 for 2 years now and not had any problems.
I've done quite a few motorway runs recently and the 'reduced engine performance turtle' message popped up on the dash.
Acceleration is now worse than a scooter.
Had an ODB reader put on it, can't remember the actual code but it said something like 'Mass air flow sensor reading too high'.
Before I replace the MAF, I have noticed splits in one of the hoses at the front of the car. Could this be causing the MAF to play up? Or am I just going to need to replace both?
Any help is much appreciated. Thanks guys.
Automotive tire Tire Wheel Musical instrument Automotive exhaust
 

·
Registered
Joined
·
16 Posts
So I've had my D2 for 2 years now and not had any problems.
I've done quite a few motorway runs recently and the 'reduced engine performance turtle' message popped up on the dash.
Acceleration is now worse than a scooter.
Had an ODB reader put on it, can't remember the actual code but it said something like 'Mass air flow sensor reading too high'.
Before I replace the MAF, I have noticed splits in one of the hoses at the front of the car. Could this be causing the MAF to play up? Or am I just going to need to replace both?
Any help is much appreciated. Thanks guys. View attachment 18352
Hi man,

Read my post:

 

·
Registered
Joined
·
16 Posts
Hi man,

Read my post:

So I've had my D2 for 2 years now and not had any problems.
I've done quite a few motorway runs recently and the 'reduced engine performance turtle' message popped up on the dash.
Acceleration is now worse than a scooter.
Had an ODB reader put on it, can't remember the actual code but it said something like 'Mass air flow sensor reading too high'.
Before I replace the MAF, I have noticed splits in one of the hoses at the front of the car. Could this be causing the MAF to play up? Or am I just going to need to replace both?
Any help is much appreciated. Thanks guys. View attachment 18352
I bought pipe here:

You can contact them there: [email protected] and ask about shipping price.
I was waiting for three days for delivering and pay 18. EUR-s for shipping.
 

·
Registered
Joined
·
1 Posts
Had the same problem last weekend, the dash send a 'reduced engine performance' info while on highway.
I popped the hood and saw the pipe with identical cracks, so my thinking was that the MAP sensor detects 'bad pressure', the turbo acts funny (I felt boost wobling) trying to keep up pressure and goes to limp mode.
Yesterday changed the pipe (20€ in Portugal) and it's done.
If you can check the MAP sensor also, sometimes they get clogged and things start acting up.

Cheers
 
1 - 6 of 6 Posts
Top