Volvo V40 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi, I have a 2014, x country D3.
My car has developed a headlamp problem. The lamps are xenon and are just fine on main beam but when I dip I’m left in near darkness with just a pool of light a few feet in front.
I generally leave the headlamp switch in auto position, and the lamps do ‘auto level‘ upon start up but the dip beam is markedly acute.
A friend is suggesting the head lamp level sensor on the rear axle may be the issue.
Any ideas on this.
 

·
Registered
2017 R Design D2
Joined
·
766 Posts
I'm not on xenon lamps, and also have below expected range on dipped, although no MOT issue. My car has a level sensor front and rear, the rear has seized solid and has been since purchase, (another item not looked at but thats a story for another day). The rear one is on the right, mounted near the shock absorber, little plastic job, with 2 rusted ball joints on mine. Before replacing, might be worth a wd40 soaking...
other brands of lubricant and rust freeing fluids are available
Font Bumper Electric blue Bicycle part Auto part
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I bought a replacement headlight sensor today from a breaker.
I had a lot of faffing about with wd40, and a grinder to get old bolds out, but hey presto, it worked, I’ve got my dipped head lights back. Cost 40 quid plus half a day faffing.
Thing is I now get an alert light showing my active bending headlamps are not functioning.
Mmmm, ???? .
Mazda me thinks.
 
1 - 4 of 4 Posts
Top