Volvo V40 Forums banner
41 - 57 of 57 Posts

·
Registered
Joined
·
1,424 Posts
Discussion Starter · #41 ·
hello

16 plate d2 r design, no camera but does have dab, sorry i thought it was the same post, i think there was a wiring diagram you posted shows it can be ran on the same circuit as the rhs light, i had hoped i could make it work without building the loom section, ive got the parts to build up a basic loom same as yours, will feed it through the boot join when i fit the new spoiler. just hoped i could activate the existing one
In that case you don't need to run it through the bellows (which is quite difficult), In the top corner of the D-pillar on thr LHS there are 2 connectors between the floor loom and the tailgate loom. The lighting runs through the 16-pin blue connector in pins 2 and 8. I would work out what pins the connector uses (positions 2 and 8 on the floor loom side will probably be empty) and add your wiring by adding these missing pins into the connector.

Pin 8 should be connected to Pin 1 of the green light unit connector (the Brown/Green wire on the existing light) and Pin 2 should be connected to Pin 2 of the light unit connector (the White/Blue wire on the existing light). The wiring in the tailgate loom is all black, so pretty difficult to work out what is what.
 

·
Registered
Joined
·
58 Posts
So I’ve gone and done this today, been very careful to make sure the right wires are in the right pins to each light unit and also in the female connector that comes from the oem wire socket. Now none of the lights work...... with or without the extra loom in. Great.

I’m assuming the middle light unit in the boot lid is also on the same circuit as that no longer works either.

Any ideas before I set fire to the car.
 

·
Registered
Joined
·
813 Posts
Has the controller just timed out because the boot has been open a long time? Have you locked up and the reopened?
 

·
Registered
Joined
·
58 Posts
Has the controller just timed out because the boot has been open a long time? Have you locked up and the reopened?
Yep, done all that about 50 times. Still nothing working. Proper peed off with it now so I’ve come away before I smash something.
 

·
Registered
Joined
·
58 Posts
Update.....

The lights are back! Worked fine tonight in the original set up. Soon as I add the loom they stop.

Have the owners who’ve done this mod had success with a single left light and the additional boot lid light or just the left boot light?
 

·
Registered
Joined
·
58 Posts
I’ve done mine today and it’s working fine. I suspect you have one of the lights Cross wired. I’ll be adding the boot light now i know what connectors I need. I bought loads of different ones but as Murphy says. Not the one I need.
Here’s the loom ends
 

Attachments

·
Registered
Joined
·
58 Posts
Been out today and pulled the loom out. 100% it’s wired right in terms of colour to colour so I’ve cut the ends off one by one and retired it the same. Works now�� and after a little look one of the connectors had a bent pin in.

Just a heads up as well that the boot lights are the same as the door lights in the bottom so a cheaper way to do it is to buy some Volvo sign down lighters for the doors and use 1 of the door lights in the boot.

Cheers for the how to.
 
41 - 57 of 57 Posts
Top