Volvo V40 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
PPM RESET V40 MODEL 2013 T3 1.6 B4164T

HELP ! Please I would like to get some advise in resetting bug in pedestrian airbag /service mesage

Hi from holland again.........
just got my 'new' V40 (okt 2012) T3 1.6 engine momentum only 16.000km with many options to make it driving mor esafe and easy.
Great car/great looks and drives very confortable on the highways in northern Holland.
As it's car-history was all known/clear to me when I bought it I knew it was involved in a light car accident(left front section)en was proffesional repaired (seen all photo's and documents)
The driver's-, passenger- and knee- airbag have been'exploded' and as requested all seatbelts(neccesary or not) all activated airbags were correctly replaced by new one's .
Airbagmodule ECU/crashdata has been resetted by the regional volvodealer .
All light/warningsignals /messages are out (NO red airbag-indication-lamp warning etc) ONLY the pedestrian protection serice message comes up ('Pedestrian service needed")(i)1 every time when ik start the engine (keyless drive)
Dealer did try several times to reset but told me he could not make any connection to it's module( CEM > ECU > PPM ) to rewrite/reload the PPM module.
There was for sure some communication with the car because I noticed day-runninglight went off and came on serveral times.
All bumper front inner-sensors where replaced (ca €800,-costs and also replaced including the cable work for those 7 sensors addional charching €50 software reload!)
Did see that after running diagnose test for PMM etc the 7 sensors went from status orange to green after 25 minutes running test diagnose(so i think they were detected and tested) but the PPM module stayed orange.
Did posted/send copy of sceen reports .
Hope somebody can give me an advise how to check or someone can send a scheme of cable work to ECU-PMM module to test cablework or something helpfull tips are welcome,
I do know that the pedestrian airbag did not went off in the accident and all cable works is located on the right side direct into the right front compartment to the PPM module/fuse case.(accident was left front section)
Dealer wants now to replace PPM module and ad extra€ 460 costs :thumbdown: without talking about additional reload costs....! Getting a bit worried now ..... Why replacing something which is not damaged.....? ECU running check was okay status so must be more in softwarebug or cable connection or ...or...
The moment I swich off the engine the message report in screen says (0) i instead of (1) i messages.

Thanks for your positive advise/remarks

Have a nice weekend :thumbup:

Michael V40

PS Hope I'll not 'score' any pedestrians in the meantime unbto repair/reset PPM....Some time ago...hm in the old days the pedestrian had to look out before crossing...........:exclamation:

GOT ALREADY AN EMAIL /ADVICE at this forum;Advise to check if the dealer did do the right updates since 2012 oktober beacause there has been several updates already as he wrote.
The dealer claims they could not get the reload correctly and I ve noticed that the updating was not completly succesfull during the session .done.No connection....
It stopped halfway during it's upload:thumbdown:
 

Attachments

·
Registered
Joined
·
729 Posts
If the dealer cannot make the connection, time to find a new dealer.....
 

·
Registered
Joined
·
3 Posts
PPM RESET V40 MODEL 2013 T3 1.6 B4164T

HELP ! Please I would like to get some advise in resetting bug in pedestrian airbag /service mesage

Hi from holland again.........
just got my 'new' V40 (okt 2012) T3 1.6 engine momentum only 16.000km with many options to make it driving mor esafe and easy.
Great car/great looks and drives very confortable on the highways in northern Holland.
As it's car-history was all known/clear to me when I bought it I knew it was involved in a light car accident(left front section)en was proffesional repaired (seen all photo's and documents)
The driver's-, passenger- and knee- airbag have been'exploded' and as requested all seatbelts(neccesary or not) all activated airbags were correctly replaced by new one's .
Airbagmodule ECU/crashdata has been resetted by the regional volvodealer .
All light/warningsignals /messages are out (NO red airbag-indication-lamp warning etc) ONLY the pedestrian protection serice message comes up ('Pedestrian service needed")(i)1 every time when ik start the engine (keyless drive)
Dealer did try several times to reset but told me he could not make any connection to it's module( CEM > ECU > PPM ) to rewrite/reload the PPM module.
There was for sure some communication with the car because I noticed day-runninglight went off and came on serveral times.
All bumper front inner-sensors where replaced (ca €800,-costs and also replaced including the cable work for those 7 sensors addional charching €50 software reload!)
Did see that after running diagnose test for PMM etc the 7 sensors went from status orange to green after 25 minutes running test diagnose(so i think they were detected and tested) but the PPM module stayed orange.
Did posted/send copy of sceen reports .
Hope somebody can give me an advise how to check or someone can send a scheme of cable work to ECU-PMM module to test cablework or something helpfull tips are welcome,
I do know that the pedestrian airbag did not went off in the accident and all cable works is located on the right side direct into the right front compartment to the PPM module/fuse case.(accident was left front section)
Dealer wants now to replace PPM module and ad extra€ 460 costs 👎 without talking about additional reload costs....! Getting a bit worried now ..... Why replacing something which is not damaged.....? ECU running check was okay status so must be more in softwarebug or cable connection or ...or...
The moment I swich off the engine the message report in screen says (0) i instead of (1) i messages.

Thanks for your positive advise/remarks

Have a nice weekend 👍

Michael V40

PS Hope I'll not 'score' any pedestrians in the meantime unbto repair/reset PPM....Some time ago...hm in the old days the pedestrian had to look out before crossing...........❗

GOT ALREADY AN EMAIL /ADVICE at this forum;Advise to check if the dealer did do the right updates since 2012 oktober beacause there has been several updates already as he wrote.
The dealer claims they could not get the reload correctly and I ve noticed that the updating was not completly succesfull during the session .done.No connection....
It stopped halfway during it's upload:thumbdown:
Just wondering if you resolved this issue as I have EXACTLY the same issue with my 2017 T3...
 
1 - 3 of 3 Posts
Top