Volvo V40 Forums banner
1 - 19 of 19 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Hi my radio and display has stopped working on my 13 plate D4 SE. There is no sound the screen is just black but the part of the screen for the climate control still works.

I have checked the fuses but they appear ok, has anyone else had this problem or is it just me? Car is booked into dealers on Monday for them to investigate.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
Well the car has spent the day in the dealers, they have said after talking to Volvos technical department that it appears the amplifier is broken and needs replacing.

Apparently the dealer hasn't come across the problem before, fingers crossed a new amplifier solves the problem later in the week.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #9 ·
Been back to garage today to have new amplifier fitted, all seems well at moment. So fingers crossed everything's ok now.

Thinking of chopping car in for a new one before March anyway, so not overly worried if fault not cured.
 

·
Registered
Joined
·
1 Posts
screen is black

greetings, the screen (tablet) incorporated on the volvo v40 CC did not turned on since this morning... Radio/Medio/My car/Tel simply does not work... the tablet just stopped work... do you guyz had some troubles with the tablet?
does it have any solution?
 

·
Registered
Joined
·
1,424 Posts
greetings, the screen (tablet) incorporated on the volvo v40 CC did not turned on since this morning... Radio/Medio/My car/Tel simply does not work... the tablet just stopped work... do you guyz had some troubles with the tablet?
does it have any solution?
The original problem on this thread was a faulty amplifier. All the media system components (the head unit, control panel, screen amplifier and DAB receiver) are all linked together on a fibre optic communication link (called the MOST bus). They are connected in a loop, so if one node fails the system will shut down, which is why there was no audio but the screen still showed the climate settings etc.

In your case, if the screen is showing nothing (not even the climate settings) then it sounds like the screen itself has failed. Do the fan control and temperature settings still work?
 

·
Registered
Joined
·
3 Posts
moillebeau

greetings, the screen (tablet) incorporated on the volvo v40 CC did not turned on since this morning... Radio/Medio/My car/Tel simply does not work... the tablet just stopped work... do you guyz had some troubles with the tablet?
does it have any solution?
My V40 developed the same problem yesterday. The fan settings and a/c still work seemingly as normal but the visual display does not show anything at all. Radio, media, sat nav, reversing camera/sensors, telephone are all out. Taking it to the garage tomorrow for repair since it's still under warranty but would appreciate any views on what might have caused this all of a sudden! I'm thinking it must be some sort of software fault affecting the screen and media system since the heating controls still work, but am really no expert.
 

·
Registered
Joined
·
999 Posts
This sounds like a very well document problem that was common on my last car, a Peugeot RCZ, like Buzby has said it was a total screen failure on the RCZ , which was a sealed unit so no repair possible, and a £1400 replacement part :crying:

Luckily when mine failed the car was still under warranty :grin2:
 

·
Registered
Joined
·
3 Posts
Indeed seems like a loose cable - they've kept it overnight to have a dig around behind the panel. Glad it's under warranty since I live in Switzerland and don't fancy shelling out megabucks for a repair... Thanks all for the advice.
 

·
Registered
Joined
·
1 Posts
My amplifier actually burnt out and filled the cabin with toxic fumes. The volume set itself to high, and there was a buzzing noise, lost all audio functions and bluetooth connection. Rang the dealer and they advised me not to drive the car, and to get it checked over by the RAC. The RAC obviously couldn't fix it so they had to take it in to the dealer for me. After 7 days the amp was replaced under warranty. Pretty worrying for that to happen to an 18 month old vehicle.
 

·
Registered
Joined
·
2 Posts
Hi my radio and display has stopped working on my 13 plate D4 SE. There is no sound the screen is just black but the part of the screen for the climate control still works.

I have checked the fuses but they appear ok, has anyone else had this problem or is it just me? Car is booked into dealers on Monday for them to investigate.
I have exactly the same issue. Exactly. Infotainment down, AC still operational.
Had diagnostics scan done. Stated something relating to the faulty earth cable…😏
Does anyone know where I can find a wiring diagram for 2014 V40 D2? Thanks.
 
1 - 19 of 19 Posts
Top