Volvo V40 Forums banner
21 - 30 of 30 Posts

·
Registered
Joined
·
15 Posts
I have just checked my HTC One M9 bluetooth settings and everything is ENABLED but I have never had the screen lock-up on my MY15 D2.

Don't know if that helps at all.
 

·
Registered
Joined
·
1 Posts
Hello, sorry if I re-up this thread to life after about 2 years but.. I think it may help someone in the same conditions. I live in Italy and today experienced what seems to be a similar problem in this thread. There was a message appearing in the screen, the same message as the open post said, but then the screen completely turned off for some seconds. Then I pressed the button to start it again and everything came back to a normal condition. I was not listening to music, so I don't know in this case, but air conditioning continued working even if the display was off. and by "off" I mean completely black, turned off, there was no air conditioning bar at the bottom. I read all of the answers here and what I can think about is some loose connected cables under the driver seat (I can see several cables there, maybe some passengers in the back seats involuntary scratched/touched some cables with feet). This thing quite scared me since the car is second-hand, 5 months, a V40 D4 Ocean Race, mid 2015.

Thanks to everyone
 

·
Registered
Joined
·
81 Posts
Just to share my experience...
Have the same problem explained by chiptivo:
"...screen would freeze and would not respond to any button press for about 30-180 seconds. The system would then completely reboot (Volvo logo, HDD spin down) and come back to life."

What I found. To my car it happens ONLY when the ambient temperature is around 0 *C or below. And it happens only after cold start at that temperature. What happens:
Enter the car, start engine... radio sounds normal, central screen displays everything, but after few seconds screen just "freezes". There is a picture on it, but it is not updated, just stays as "video on pause". Right now radio stops. From that moment I can always count exactly 30 seconds and... reboot, Volvo logo, HDD spins down/up and.... everything is fine back.
No problem during summers, but when winters come again.. everything starts again.
Checked and reconnected all connectors in CEM, behind central screen, DVD player, connector to central console, connectors at audio module under the seat - No success.
Next winter will check chiptivo's assumption about possible relation to phone connection. My phone is iPhone 6.
But that clear relation to the temperature... I think that this is not caused by the phone, but will check.
 

·
Registered
Joined
·
1 Posts
It's possibly a loose connection on the CAN or MOST bus connectors on screen (which is the Infotainment Control Module, or ICM). If it went off completely (including losing the climate info at the bottom of the screen) then it's probably a connection at the back of the screen, which isn't easy to get to (it requires partial dismantling of the dash).

If you still had the climate info bar on the bottom of the screen but the rest was blank then it's most likely gone into MOST Lock, where the optic fibre MOST bus(a ring circuit where the data only travels round from node to node in one direction) shuts down. It's actually a security feature to prevent stolen (or second-hand) audio modules being used - if the ICM detects a node whose serial it doesn't recognise it shuts down the MOST bus. It can also be triggered by a break in the MOST bus ring circuit that stops the modules responding. This sometimes happens due to the MOST connection to the AUD amplifier module (a black rectangular connector with 2 orange-jacketed plastic fibres in it) under the seat not being inserted in the socket fully and then being dislodged by a rear seat passenger's feet. That one is easy enough to check, but would only apply if you could still see the climate info (which is supplied to the ICM screen over the CAN bus connection and isn't affected by the MOST Lock).
It's possibly a loose connection on the CAN or MOST bus connectors on screen (which is the Infotainment Control Module, or ICM). If it went off completely (including losing the climate info at the bottom of the screen) then it's probably a connection at the back of the screen, which isn't easy to get to (it requires partial dismantling of the dash).

If you still had the climate info bar on the bottom of the screen but the rest was blank then it's most likely gone into MOST Lock, where the optic fibre MOST bus(a ring circuit where the data only travels round from node to node in one direction) shuts down. It's actually a security feature to prevent stolen (or second-hand) audio modules being used - if the ICM detects a node whose serial it doesn't recognise it shuts down the MOST bus. It can also be triggered by a break in the MOST bus ring circuit that stops the modules responding. This sometimes happens due to the MOST connection to the AUD amplifier module (a black rectangular connector with 2 orange-jacketed plastic fibres in it) under the seat not being inserted in the socket fully and then being dislodged by a rear seat passenger's feet. That one is easy enough to check, but would only apply if you could still see the climate info (which is supplied to the ICM screen over the CAN bus connection and isn't affected by the MOST Lock).


Hello
all well
I wonder if you can help me
I'm having problems with the icm

I'm new to the group
and I have a v40cc
and my icm
it has an apparent weather bar but no screen after 2 minutes on
16940
 

·
Registered
Joined
·
6 Posts
Hi guys!
I didn't find my problem.
I have a Volvo V40 2013.
I turn on the multimedia button, but the GPS message appears and then it looks as if I was looking ... "Navigation, please wait ..."
This message does not come out, no button works, but the air conditioning functions appear at the bottom of the screen.
I have already disconnected the cables under the passenger seat, but nothing has changed.
If you connect the USB cable to the phone, it charges the phone after a few seconds stops charging and then starts charging again. After a few seconds, it stops charging and starts charging again. It looks like you are restarting the system.
But no matter what you do, only the function of the air conditioner works. No other, the Radio, Media and My Car buttons do not work.
Only the function "Navigation, please wait ..." appears
I appreciate if anyone can help me.
Bruno
 

·
Registered
Joined
·
6 Posts
Hi Guys!

I have a 2013 Volvo V40 D3 diesel.

My screen goes out and when I turn on the sound again it doesn't recognize anything... the climate information is below, it works perfectly.
However, the sound buttons do not work, only on the steering wheel.

No gps, no radio, no media, no My Car... nothing!

I have already disconnected the terminals under the bank and nothing. Suddenly, on a beautiful sunny day, everything goes back to normal. But another day, the problem comes back.

Could anybody help me?

If I use a contact cleaner on the terminals, does it improve?

Thank you!
 

·
Registered
Joined
·
2 Posts
Well this one is stupid, my phone charger (charging from car) fell into cigaret outlet - music disappeared right away. All fuses has been checked 3x - nothing!

car is 2012 V40 D2

And all of the symptoms as we all have on this thread.

On my path to find out where is IMC located and MOST...
 

·
Registered
Joined
·
81 Posts
@Kalviits
Did you check all boxes with fuses? There are fuses in three places - under the glovebox(LHD car), under the front right seat and in the engine compartment - black box just right to the accumulator.
 

·
Registered
Joined
·
2 Posts
Yes, checked all the boxes and all the fuses. Will do it again, this time will try with contact spray - I doubt that it will do anything.

One thing Im not certain - if I get 2nd hand ICM, will it work straight away, or some coding will be needed. Read bunch of varieties? And is the ICM the screen itself or the module is somewhere else?
 

·
Registered
Joined
·
81 Posts
All computer modules are coded and will not work from another car.
 
21 - 30 of 30 Posts
Top