Volvo V40 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter #1
Just thought I would give you guys my experience I had during my leave, it may help some of you in the future.
My main battery just died, had it replaced with same, and car kept giving me Battery charging, so no stop start. When stop/start worked, it was for about 10 sec, and car would start, with battery charging displayed no matter how far I drove.


So it turned out, the secondary battery in the front bumper was stuffed. This is backup and start/stop battery. It gave about 5 years life, but here is the funny part:


The last year when connecting Vida I would get some strange errors, small things. But there was nothing wrong with the car or components from the error, like left rear door lock. The lock was working perfectly, but kept getting the error, start control unit -bus signal message failures, steering column lock etc.

After replacement of battery, and resetting battery counter, and all other codes, the car drives better, as in gear changes are smoother, it's like a new car. And all these codes are gone for good, none have showed up again in the last 2 weeks, as it normally took less than a day......


Seems like this battery does play a big part with the main battery, and electronics. Have yours checked if your car starts behaving strangely!!
And no need to buy it from Volvo, really expensive.
 

·
Registered
Joined
·
2 Posts
Just thought I would give you guys my experience I had during my leave, it may help some of you in the future.
My main battery just died, had it replaced with same, and car kept giving me Battery charging, so no stop start. When stop/start worked, it was for about 10 sec, and car would start, with battery charging displayed no matter how far I drove.


So it turned out, the secondary battery in the front bumper was stuffed. This is backup and start/stop battery. It gave about 5 years life, but here is the funny part:


The last year when connecting Vida I would get some strange errors, small things. But there was nothing wrong with the car or components from the error, like left rear door lock. The lock was working perfectly, but kept getting the error, start control unit -bus signal message failures, steering column lock etc.

After replacement of battery, and resetting battery counter, and all other codes, the car drives better, as in gear changes are smoother, it's like a new car. And all these codes are gone for good, none have showed up again in the last 2 weeks, as it normally took less than a day......


Seems like this battery does play a big part with the main battery, and electronics. Have yours checked if your car starts behaving strangely!!
And no need to buy it from Volvo, really expensive.
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


I have just replaced the main battery in my V40 and I am getting similar signs as you described. So it appears I am also going to have to replace the secondary battery as well.

I did speak to the local Volvo dealer who said that it was no big deal to let the secondary battery go flat, as all that would do is prevent activation of the stop/start function, which I loath anyway and usually bypass whenever driving the car. But then again the electrical system was designed to run properly with the 2 batteries, so will go ahead and replace the 2nd one as well.

Are you aware of how the secondary battery is accessed and what the specs of it are?( Amp hours etc)

I propose purchasing a suitable battery and getting my local garage to replace it, rather than having a Volvo Dealer supply and fit an identical battery and then charge me a gazillion bucks for the job.
 

·
Registered
Joined
·
341 Posts
Anyone know where is this battery in the engine bay? I could only see the main battery in the top right side of the engine, is this secondary battery elsewhere? I guess this is why when the car resumes from 'start stop' the lights would not dim or wipers stop midway (had that quirk in my previous cars).
 
1 - 5 of 5 Posts
Top